”网络“项目搭建----知识点汇集(文末含实施文档-Cisco设备)

发布于:2021-10-16 19:48:03

一、网络项目名称

某某公司网络搭建/升级


二、项目描述

企业搬迁、网络升级(新增或优化)。几个办公网络(人事、财务、销售、开发、运维等)


三、技术点

VLAN 、NAT、 DHCP 、中继、ACL
{技术点总结:vlan nat 热备份HSRP 生成树(spanning tree) dhcp ospf 中继链路 acl}


四、规划

每个部门划分到同一个vlan中,二层交换机采用H3C,华为不可管理的交换机 { 交换机:Cisco 型号2960 -24接口 -价格4000元、 h3c- 24接口-全千兆-价格1000元。 3560三层交换机}。
vlan1-5代表不同的部门 :
(人事)vlan1:192.168.10.0 /24 、(财务) vlan2:192.168.20.0/24 、(销售) vlan3:192.168.30.0/24 、(开发)vlan4:192.168.40.0/24 、(运维)vlan5:192.168.50.0/24
三层交换机:配置dhcp,有几个vlan,配置几个dhcp的pool池。


五、扩充

1、{ 20栋厂房,每个厂房20个货架,每个货架100台机器,第5个厂房的第6个货架的第7台机器ip是多少?
10.5.6.7/24


私有地址


A:10.0.0.0-10.255.255.255/8
B:172.16.0.0-172.31.255.255/16
C:192.168.0.0-192.168.255.255/24 }


2、vlan
名称:虚拟局域网。
作用:用于隔离广播域,防止广播风暴。
应用:一般vlan承载的主机数目可达150~200,使用vlan技术,可以用于部门或功能划分创建vlan,为了实现不同交换机上的相同vlan通信,需要配置trunk中继。为了实现不同vlan间的通信,需要配置三层交换。


3、OSI七层
物理层
数据链路层
网络层
传输层
会话层
表示层
应用层


4、tcp三次握手和四次挥手

总结三次握手过程:
第一次握手:起初两端都处于CLOSED关闭状态,Client将标志位SYN置为1,随机产生一个值seq=x,并将该数据包发送给Server,Client进入SYN-SENT状态,等待Server确认;
第二次握手:Server收到数据包后由标志位SYN=1得知Client请求建立连接,Server将标志位SYN和ACK都置为1,ack=x+1,随机产生一个值seq=y,并将该数据包发送给Client以确认连接请求,Server进入SYN-RCVD状态,此时操作系统为该TCP连接分配TCP缓存和变量;
第三次握手:Client收到确认后,检查ack是否为x+1,ACK是否为1,如果正确则将标志位ACK置为1,ack=y+1,并且此时操作系统为该TCP连接分配TCP缓存和变量,并将该数据包发送给Server,Server检查ack是否为y+1,ACK是否为1,如果正确则连接建立成功,Client和Server进入ESTABLISHED状态,完成三次握手,随后Client和Server就可以开始传输数据。



总结四次挥手过程:
起初A和B处于ESTABLISHED状态??A发出连接释放报文段并处于FIN-WAIT-1状态??B发出确认报文段且进入CLOSE-WAIT状态??A收到确认后,进入FIN-WAIT-2状态,等待B的连接释放报文段??B没有要向A发出的数据,B发出连接释放报文段且进入LAST-ACK状态??A发出确认报文段且进入TIME-WAIT状态??B收到确认报文段后进入CLOSED状态??A经过等待计时器时间2MSL后,进入CLOSED状态。


5、HSRP:热备份路由协议。思科私有协议
VRRP和HSRP的区别:
1、两个都支持认证
2、两个都支持抢占,VRRP抢占默认开启
3、都可以做负载均衡(不同组之间)
4、HSRP中路由状态有6中,VRRP有3种
5、HSRP中叫做active路由器和standby路由器,VRRP叫做master路由器和backup路由器
6、HSRP standby路由器也主动发送hello包,这样HSRP活动路由器可以发现网络当中的备份路由器
VRRP backup路由器不主动发送hello包,所以master路由器不可以主动发现网络当中的backup路由器
7、HSRP虚拟路由器的Ip不能是活动路由器接口的ip,VRRP可以
8、HSRP是cisco私有,VRRP公有
9、HSRP支持追踪,VRRP不支持追踪
10、HSRP的standby路由器选举只有优先级起作用,ip地址不起作用。
VRRP的活动路由器选举优先级和ip地址都起作用
11、HSRP的hello时间为3秒,间隔hold时间为10秒
VRRP中失效间隔时间是通告间隔时间的3倍,通告间隔时间默认1秒
12、VRRP支持辞职,HSRP不支持辞职(辞职是指将接口优先级改为0后不参加活动路由器的选举)
13、MAC:00-00-5e-00-01-01 VRRP 组播地址224.0.0.18
00-00-0c-07-ac-01 HSRP 组播地址 224.0.0.2


六、配置命令:

1、配置路由成为dhcp服务器
{ vlan 10 :192.168.10.252}
建立地址池:
Switch(config)# ip dhcp pool v10
设置要分配的子网
Switch(dhcp-config)#network 192.168.10.0 255.255.255.0
设置分配子网的网关为vlan10的ip地址,即vlan10 会分配192.168.10.0网段的ip地址。
Switch(dhcp-config)#default-router 192.168.10.252


vlan的划分、vlan的ip地址配置、nat地址转换、nat映射多路复用、acl设置。
《案例详解》
实验目的:通过使用常见网络协议配置上图*私峁梗迪帜谕煌瑅lan的负载均衡与公网的正常访问。


首先配置4台交换机,均创建vlan10与vlan20
Switch>enable
Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
其他3台均按上面命令配置。


二层交换机Sw1的配置
需要将f0/3口加入vlan10
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport access vlan 10
再进入f0/1口与f0/2口配置为中继链路
Switch(config)#interface range fastEthernet 0/1-2
Switch(config-if-range)#switchport mode trunk


二层交换机Sw2的配置
需要将f0/3口加入vlan20
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport access vlan 20
再进入f0/1口与f0/2口配置为中继链路
Switch(config)#interface range fastEthernet 0/1-2
Switch(config-if-range)#switchport mode trunk


三层交换机ms1的配置
为f0/4配置ip地址
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.1.2 255.255.255.0


为vlan10与vlan20配置ip地址
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.252 255.255.255.0
Switch(config)#interface vlan 20
Switch(config-if)#ip address 192.168.20.252 255.255.255.0


进入f0/1-3口配置为中继链路
Switch(config)#interface range fastEthernet 0/1-3
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk


设置STP生成树协议的优先级使其称为vlan10的主根vlan20的次根
Switch(config)#spanning-tree vlan 10 root primary
Switch(config)#spanning-tree vlan 20 root secondary


配置HSRP协议的虚拟路由器ip
Switch(config)#interface vlan 10
Switch(config-if)#standby 10 ip 192.168.10.254
Switch(config)#interface vlan 20
Switch(config-if)#standby 20 ip 192.168.20.254


使其称为vlan10的活跃路由器vlan20的备份路由器
Switch(config)#interface vlan 10
Switch(config-if)#standby 10 priority 105
Switch(config-if)#standby 10 preempt
Switch(config)#interface vlan 20
Switch(config-if)#standby 20 preempt
开启端口跟踪
Switch(config)#interface vlan 10
Switch(config-if)#standby 10 track fastEthernet 0/4


运行ospf动态路由
首先开启路由功能
Switch(config)#ip routing
Switch(config)#router ospf 1
Switch(config-router)#network 192.168.1.0 0.0.0.255 area 0
Switch(config-router)#network 192.168.10.0 0.0.0.255 area 0
Switch(config-router)#network 192.168.20.0 0.0.0.255 area 0
添加默认路由
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1


三层交换机ms2的配置
为f0/4配置ip地址
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.2.2 255.255.255.0


为vlan10与vlan20配置ip地址
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.253 255.255.255.0
Switch(config)#interface vlan 20
Switch(config-if)#ip address 192.168.20.253 255.255.255.0


进入f0/1-3口配置为中继链路
Switch(config)#interface range fastEthernet 0/1-3
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk


设置STP生成树协议的优先级使其称为vlan20的主根vlan10的次根
Switch(config)#spanning-tree vlan 20 root primary
Switch(config)#spanning-tree vlan 10 root secondary


配置HSRP协议的虚拟路由器ip
Switch(config)#interface vlan 10
Switch(config-if)#standby 10 ip 192.168.10.254
Switch(config)#interface vlan 20
Switch(config-if)#standby 20 ip 192.168.20.254


使其称为vlan10的活跃路由器vlan20的备份路由器
Switch(config)#interface vlan 20
Switch(config-if)#standby 20 priority 105
Switch(config-if)#standby 20 preempt
Switch(config)#interface vlan 10
Switch(config-if)#standby 10 preempt
开启端口跟踪
Switch(config)#interface vlan 20


Switch(config-if)#standby 20 track fastEthernet 0/4


运行ospf动态路由
首先开启路由功能
Switch(config)#ip routing
Switch(config)#router ospf 1
Switch(config-router)#network 192.168.2.0 0.0.0.255 area 0
Switch(config-router)#network 192.168.10.0 0.0.0.255 area 0
Switch(config-router)#network 192.168.20.0 0.0.0.255 area 0
添加默认路由
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.1


路由器配置
三个接口配置ip
Router(config)#interface g0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config)#interface g0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config)#interface g0/2
Router(config-if)#ip address 100.0.0.1 255.0.0.0
Router(config-if)#no shutdown


开启ospf
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
开启nat功能
Router(config)#access-list 1 permit any
Router(config)#ip nat inside source list 1 interface g0/2 overload
Router(config)#interface g0/2
Router(config-if)#ip nat outside
Router(config)#interface g0/0
Router(config-if)#ip nat inside
Router(config)#interface g0/1
Router(config-if)#ip nat inside

相关推荐

最新更新

猜你喜欢